Sunday, June 16, 2013

Login delay from external web application server after CMS restart

After restarting the Central Management Server (CMS) there is a login delay up to several minutes until the login finally proceeds. This is happening from an external web application server (WAS).
Environment
SAP BusinessObjects (any version)
Microsoft Windows Server 2008 R2 (hosting the CMS)
External Web Application Server (WAS)
The cause for this behaviour is the Microsoft Windows Server 2008 R2 Stealth Mode:
Stealth mode blocks outgoing ICMP unreachable and TCP reset messages for a port when no application is listening on that port.
(Source: http://technet.microsoft.com/en-us/library/dd448557%28WS.10%29)
Having Stealth Mode Enabled will cause the Windows Server not to respond with a TCP RESET to the connection attempt by the WAS but rather
to drop the packet leaving the other host waiting for a timeout.
solution
There are 2 possible resolutions to this problem.
(1) Disable Stealth Mode
If you do not require to use Microsoft Windows Stealth Modeyou can disable it as described in the following TechNet Article:
http://msdn.microsoft.com/en-us/library/ff720058%28v=PROT.10%29
(2) Fix the CMS Request Port
If you dowant to keep Microsoft Windows Stealth Modeenabled you can manually set the CMS Request Port on your SAP BusinessObjects
installation. This causes the CMS to always bind to the same port and will not cause any problems as the cached request port will be re-used. To
set the Request Port, please see the Administration Guide of your SAP BusinessObjects solution.
  •  For SAP BO XI 3.1: 3. Configuring server settings, Server host identification options 
  •  For SAP BO BI 4.0: 9.1.12.2 Server host identification options 

Hope you find this useful.
Cheers,
Umang Patel
+919979084870
SAP BO BI Solution Architect/Consultant

1 comment: